1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Before reporting your bug, please read this thread: Reporting bugs & finding your game logs.
    Dismiss Notice

[2.35.3] Hades probably dropping games

Discussion in 'Critical Bugs' started by jitsuc4, Aug 31, 2018.

  1. jitsuc4

    jitsuc4 Moderator

    Messages:
    387
    Likes Received:
    215
    Trophy Points:
    43
    Kinda reviving this, but since Lisk wrote in there he identified one possible cause, I decided to make a new thread. Also since I've got games to drop in a solo custom game, this might make it easier to figure out the issue.

    • All games seem to have Hades in play
    • Games usually drop late game, like 18+ (so maybe due to some summon/send interaction?)
    • Some seem to drop when imps don't get ported?
    • Can't be, since games also drop at the start of waves (e.g. 14)
    Lisk 08/08/2018
    yeah that looks like a different, much more rarer one. I will probably fix that once we switch servers to another provider that would give us more visibility into remote crash logs

    I don't have a 100% repro on this yet, but it happened in most customs I tried today, but never consistently. I had no drops with Gateguard, Harbinger, LoD. Only with Hades. The last clip in the video is particularly funny, since I tried harbingers and swapped one for Hades later on with the game instantly dropping on wave start.

    Since there's no obvious pattern whatsoever, I assume it's something weird, but definitely seems to be related to the way Hades works. Some weird summon behavior (only summoner with 2x insta summon), some timer issues not getting handled properly, something to do with porting units after clearing come to mind.

    Note: All games were started in a freshly launched client, no prior games or anything.

    - Video:


    - Logs:
    I've included the logs used in the clips, as well as some earlier attempts which are more spammy builds though.
     

    Attached Files:

    Last edited: Aug 31, 2018
    Lisk likes this.
  2. Lisk

    Lisk Director Staff Member

    Messages:
    2,542
    Likes Received:
    1,051
    Trophy Points:
    113
    Thanks for the extensive testing, video, and logs. It's very helpful to know that you were able to experience it in a solo custom game.

    For this particular bug, a repro is probably going to be the most helpful.

    Do you know an approx success rate of the 6 rows of hades test? I tried doing it on wave 8 10 times, but wasn't able to repro. Just wondering how long I should keep trying. Thanks!

    Tried about 50 waves now, still no repro. Tried doing like 8 rows, as well as opening lane 2.
     
    Last edited: Sep 12, 2018
  3. Lisk

    Lisk Director Staff Member

    Messages:
    2,542
    Likes Received:
    1,051
    Trophy Points:
    113
    I even tried changing the mana cost to 3, so Hades really spams imps, but didn't freeze still :(

    Screenshot - 9_12_2018 , 4_54_37 PM.png
     
  4. jitsuc4

    jitsuc4 Moderator

    Messages:
    387
    Likes Received:
    215
    Trophy Points:
    43
    The only thing I did differently: I never repeated any wave (other than 21 with increasing buff). I just started at wave 1 and let the Hades clear all waves, just -starting the wave to save some time.

    Sadly no, as I mentioned there seems to be no pattern on when or why this happens. The fastest I got was on wave 4 (starting at wave 1), the slowest was at 21.20 and retrying that a couple of times (also starting from wave 1). That's already varying between 4 and >50 tries.

    I was hoping there might be something in the logs, but since there's apparently nothing, I'll try to find a more consistent way.

    Just tried it again to see if it's still happening, from w1 and dropped at the start of w19: (this log has the .txt dump as well, the others up till now didn't - does that only happen if you wait a bit after disconnecting?)

    upload_2018-9-13_7-44-4.png

    Legion TD 2 Screenshot 9-13-18 08.48.28.png

    Edit: Did another game with one Hades, started wave 1-8 for like 40 minutes, nothing. Filled up to three rows and it dropped after another 4 minutes (7C81806778FA8C45, in the logs as well). It is just super weird...
     
    Last edited: Sep 12, 2018
    Lisk likes this.
  5. Lisk

    Lisk Director Staff Member

    Messages:
    2,542
    Likes Received:
    1,051
    Trophy Points:
    113
    Np. Do you know if the rate is closer to 1 crash per 10 minutes of testing, 1 crash per hour of testing, or 1 crash per 6 hours of testing? something just approximate would help.

    Good news is, I was able to reproduce it one single time right before I was about to sign off yesterday. This was enough to get a stacktrace which I'm going to take a closer look at today, after taking care of other things. My guess is the crash had to do with Hades casting multiple imps, as you suspected.
     
  6. jitsuc4

    jitsuc4 Moderator

    Messages:
    387
    Likes Received:
    215
    Trophy Points:
    43
    From my custom games (11) it's average of 1 crash per 11.3 minutes, with max. at 44.5 min and min. 2.1 min.
     
    Lisk likes this.
  7. jitsuc4

    jitsuc4 Moderator

    Messages:
    387
    Likes Received:
    215
    Trophy Points:
    43
    Seems like it won't happen in custom games anymore, this one timed out due to game time limit. Legion TD 2 Screenshot 9-15-18 10.35.43.png
     
    Lisk likes this.