1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stuck at map view after launching game (No menu/GUI)

Discussion in 'Resolved Bugs' started by Auras, Jul 6, 2017.

  1. Auras

    Auras Member

    Messages:
    6
    Likes Received:
    4
    Trophy Points:
    3

    Attached Files:

    Last edited by a moderator: Aug 8, 2017
    Samantha likes this.
  2. Jules

    Jules Developer Staff Member

    Messages:
    2,004
    Likes Received:
    2,184
    Trophy Points:
    113
    Thanks for the report, Auras. Can you also give us your output_log.txt?

    2017-04-24_15h45_14.png
     
  3. Auras

    Auras Member

    Messages:
    6
    Likes Received:
    4
    Trophy Points:
    3
    Sure Jules, here it is. I checked other people output_logs when they attached them on the forum and I think the issue is CoherentUIGT_Native.dll. They get the message in log something like "Intializing Coherent UI GT ver. 1.10.1.1" and I get "Failed to load .../Legion TD 2/Legion TD 2_Data/Plugins/CoherentUIGT_Native.dll' with error 'The specified module could not be found."
     

    Attached Files:

    Last edited: Jul 7, 2017
    Jules likes this.
  4. Lisk

    Lisk Director Staff Member

    Messages:
    2,767
    Likes Received:
    1,180
    Trophy Points:
    113
  5. Auras

    Auras Member

    Messages:
    6
    Likes Received:
    4
    Trophy Points:
    3
    @Lisk Hello. I searched on the forum a few days ago and found the same post. Unfortunately it doesn't help me, I already had Visual C++ 2013 redistributable and the Update for Windows 8.1 for x64-based Systems (KB2999226) installed.
     

    Attached Files:

  6. Lisk

    Lisk Director Staff Member

    Messages:
    2,767
    Likes Received:
    1,180
    Trophy Points:
    113
    Thanks for the update and screenshots.

    Do you have the "Update for Universal C Runtime" mentioned in the last two posts?

    Also can you verify that CoherentUIGT_Native.dll exists at this path:
     
  7. Auras

    Auras Member

    Messages:
    6
    Likes Received:
    4
    Trophy Points:
    3
    Yes, I have the update for universal c runtime , that's the KB2999226. I do have the dll, here is a image with that folder .
     

    Attached Files:

    Lisk likes this.
  8. Lisk

    Lisk Director Staff Member

    Messages:
    2,767
    Likes Received:
    1,180
    Trophy Points:
    113
    Thanks for the clarification and screenshot. Sorry about misunderstanding about the KB2999226.

    I filed a support ticket with the Coherent UI team and I will follow up as soon as I hear from them.
     
    Auras likes this.
  9. Lisk

    Lisk Director Staff Member

    Messages:
    2,767
    Likes Received:
    1,180
    Trophy Points:
    113
    @Auras I haven't heard back from the Coherent UI team yet, but can you try renaming

    D:\steam\steamapps\common\Legion TD 2\Legion TD 2_Data\Managed\CoherentUIGTNET.dll

    to

    D:\steam\steamapps\common\Legion TD 2\Legion TD 2_Data\Managed\CoherentUIGTNet.dll

    (make the NET lowercase to Net)

    and see if that fixes the problem? if not, we'll wait to see what Coherent UI says.

    Edit: fixed the paths
     
    Last edited: Jul 17, 2017
  10. Elad

    Elad Member

    Messages:
    2
    Likes Received:
    2
    Trophy Points:
    3
    @Lisk I'm having the same issues as Auras. I've attached my output_log.txt, and a copy of my Plugin folder contents (looks the same as Auras). I don't see a copy of the dll file you suggested changing the name on in either plugin folder - is it somewhere else and I missed that info?
     

    Attached Files:

    Last edited: Jul 15, 2017
    Lisk likes this.
  11. Lisk

    Lisk Director Staff Member

    Messages:
    2,767
    Likes Received:
    1,180
    Trophy Points:
    113
    Thanks for the log and screenshot.

    My mistake, the file is actually located at:

    D:\steam\steamapps\common\Legion TD 2\Legion TD 2_Data\Managed\CoherentUIGTNET.dll
     
  12. Auras

    Auras Member

    Messages:
    6
    Likes Received:
    4
    Trophy Points:
    3
    I checked, the dll is in the Managed folder .
    Edit : Sorry, I just saw you were talking to Elad. My bad :oops:
     
  13. Lisk

    Lisk Director Staff Member

    Messages:
    2,767
    Likes Received:
    1,180
    Trophy Points:
    113
    @Auras @Elad

    I am assuming you are still having the same problem. I just bumped my thread with Coherent since I haven't heard back from them yet. There might not be an easy solution for this.

    This isn't a solution, but have you ever played Guild Wars 2 or Planetary Annihilation or Smite? Those are some games that use Coherent UI off the top of my head. It would be useful to know if you've played those games without any issues.

    Edit: also I renamed the thread to be more descriptive
     
    Elad likes this.
  14. Elad

    Elad Member

    Messages:
    2
    Likes Received:
    2
    Trophy Points:
    3
    @Lisk I'm still having the same problems. I checked the CoherentUIGTNet.dll and mine already was "Net". I actually have both Smite and Guildwars 2 installed on this computer and have played both without issue (actually just reinstalled Guildwars 2 a few weeks ago and have been playing it recently). I fired them both up tonight just to double check, and both Smite and Guildwars 2 ran fine.
     
    Lisk likes this.
  15. Auras

    Auras Member

    Messages:
    6
    Likes Received:
    4
    Trophy Points:
    3
    @Lisk Yes, I used to play Smite without any problem
     
    Lisk likes this.
  16. Lisk

    Lisk Director Staff Member

    Messages:
    2,767
    Likes Received:
    1,180
    Trophy Points:
    113
    Thanks for the update. I am waiting on Coherent UI support and will follow up when possible. Keeping this thread stickied since it is an ongoing issue for now.
     
  17. Lisk

    Lisk Director Staff Member

    Messages:
    2,767
    Likes Received:
    1,180
    Trophy Points:
    113
    @Auras please see the following response:

    Let me know the result so I can get back to them.
     

    Attached Files:

  18. Lisk

    Lisk Director Staff Member

    Messages:
    2,767
    Likes Received:
    1,180
    Trophy Points:
    113
    Hey @Auras were you able to try the above file?
     
  19. frozenskull77

    frozenskull77 Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    got the same issue :/ is there a solution to fix this launch bug ?
     
  20. Bluelightningg

    Bluelightningg Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    i have the same issue :( can someone help me?