1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[v1.59r-1..65](Linux/wine) Dark Screen (low brightness ig)

Discussion in 'Resolved Bugs' started by ggg, Jan 16, 2018.

  1. ggg

    ggg Member

    Messages:
    2
    Likes Received:
    2
    Trophy Points:
    3
    Hi,
    as you can read in the title this is a bug that AFAIK only occured on Linux with wine so far and since Linux isn't on your list of the supported OSes I can understand if there is really no priority for you to fix this bug.

    However since I am playing LTD2 only on Linux and I believe I am not alone it would be really nice if you could do us a favor and fix this bug ;)

    SUMMARY:
    When starting LTD2 it looks normal like it should, but after a few seconds the brightness goes down and it's rly hard to see certain elements ingame. Especially at night the game is nearly unplayable.
    But every few seconds the brightness goes up again for a spilt second and then it goes down again.
    Here is a video for better understanding (in second 16-17 is the brightness going down nad in 24 it goes suddenly up:


    As you can see in the video the moment the brightness goes down the terminal states:
    fixme:d3d11:d3d11_immediate_context_HSSetShader Dynamic linking is not implemented yet.
    fixme:d3d11:d3d11_immediate_context_PSSetShader Dynamic linking is not implemented yet.
    fixme:d3d11:d3d11_immediate_context_IAGetVertexBuffers Failed to get vertex buffer 16.


    and repeats it all over again.

    So it looks like that the brightness bug is related to dx11 but LTD2 should also be able to use dx9 (which is 100% supported in wine AFAIK). So this is just my speculation but maybe it's possible that the game is trying to use dx11 even tough it can't and should use dx9 instead.

    But if this theory would be true idk why the lightness would go up again even if just for a split second :/

    TESTING SETUP:
    OS: ubuntu 17.10
    wine Version:
    wine-2.21 (Staging)
    wine prefixes: tested in clean 32 and 64 bit prefixes
    Graphic cards: tested with current drivers (and cards/chips) from intel and nvidia (NOT tested with AMD)
    LTD2 Versions: I was able to repoduce this bug in the versions form 1.59r-1.66 but I just started playing with 1.59r so it may have occured before.

    HOW TO REPODUCE:
    Get ubuntu 17.10 and install the latest wine-staging on it.
    Then install steam according to the WINEHQ guide.
    Then install d3dx9 via winetricks
    Now install Legion TD 2 like u would install any Windows game via Steam and start it.

    Just contact if you need more infos.

    Thx for reading this Bug report and I would be really happy about a fix :)

    Yours faithfully
    Georg Schümann
     

    Attached Files:

    Lisk likes this.
  2. Lisk

    Lisk Director Staff Member

    Messages:
    2,719
    Likes Received:
    1,161
    Trophy Points:
    113
    Thanks for this post, and sorry for the delayed response. I haven't been able to prioritize Linux support unfortunately, but I'll keep track of this thread for when Linux support is worked on.

    I think this may be true. I think the UI library that we use (Coherent GT) dropped DX9 support.

    If you go to graphics options in Legion TD 2 in game and choose the lowest settings, does it help at all?
     
  3. ggg

    ggg Member

    Messages:
    2
    Likes Received:
    2
    Trophy Points:
    3
    Hi thanks for your reply.

    Changing the options to the lowest possible settings and turning of shadows isn't helping.

    I also tried to set the -force-d3d9 parameter in steam which resulted in a crash after a few seconds when I started the game.

    You should probably change the system requirements on steam since they say that dx9 is enough but that seems sadly to be wrong.

    Anyway thanks for taking the effort and trying to support Linux.
     
    Lisk likes this.
  4. Lisk

    Lisk Director Staff Member

    Messages:
    2,719
    Likes Received:
    1,161
    Trophy Points:
    113
    Thanks for the update. I am sorry that the -force-d3d9 parameter didn't work (it used to work during alpha testing).

    Tagging @Jules to get the Steam description updated.
     
  5. CORR0S1VE

    CORR0S1VE Member

    Messages:
    15
    Likes Received:
    10
    Trophy Points:
    3
    Just flagging that this is still an issue, Ubuntu, latest Nvidia drivers, DX, etc
     
  6. Lisk

    Lisk Director Staff Member

    Messages:
    2,719
    Likes Received:
    1,161
    Trophy Points:
    113
    Thanks - I think it's somehow running the game with Gamma lightspace instead of Linear. I don't know of a fix yet, though, unfortunately.